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Introduction & Installation



Introduction
This macro pack contains over 100 macro functions for astrophotography editing, including features such 
as colour-preserving tone stretching, star size and intensity reduction, bandpass sharpening and more. 
These macros aim to be completely non-destructive where possible, avoiding Merge Down/Merge Visible 
which results in redundant pixel layers.

Please note: most macros are designed for use in a 32-bit per channel pixel format—e.g. in 
DeepSkyStacker when saving to a TIFF this is referred to as ‘32-bit/ch Rational’. The macro results may look 
incorrect if you try to use them in 16-bit or 8-bit. If you are stacking in Affinity Photo, this will always default 
to 32-bit precision anyway.

I have also included a second category of macros for use with 16-bit per channel editing—these do not 
include the tone stretching macros (which should always be done in 32-bit) and composition macros, but 
they can be used after tone stretching if you flatten/merge and convert to 16-bit. There are macros at the 
bottom of the 32-bit category that will help with this 16-bit conversion procedure. Taking this approach will 
speed up editing: older or weaker hardware may struggle with 32-bit compositing, and 16-bit compositing is 
less taxing on both the CPU and GPU.

You will see which macros can be used in 16-bit by looking underneath the macro title in this readme: you 
will typically see RGB/32 but any macro that also has RGB/16 will be available in the 16-bit macro category.

I have also recorded a video that covers some of V15’s new functionality. You can view it on YouTube by 
clicking here.



Installation
1. Extract the .afmacros files to a directory of your choice.

2. Drag drop the .afmacros files, e.g. JR - Astrophotography V19 (32-bit).afmacros, onto Affinity Photo’s user 
interface and release the mouse button.

3. The macro category will be installed and the Library panel will automatically appear, displaying the new 
macros.

4. The Library panel can be toggled on/off by going to Window>Library. The macros can also be installed 
via this panel by clicking on the panel options and choosing Import Macros.



You will find four .afmacros files that can be installed:

• JR - Astrophotography Stretching
• JR - Astrophotography 32-bit
• JR - Astrophotography 16-bit
• JR - Astrophotography Data Setups

If you stack in Affinity Photo, you will always default to working in 32-bit, therefore you should install the 32-bit macros and the 
stretching macros. The same applies if you stack in other software and save as a 32-bit floating point / rational TIFF or FIT file, 
which you then open in Affinity Photo to edit further. Stretching macros should always be run in 32-bit, and not 16-bit.

The 16-bit macros are primarily for workflows where you will bring in a post-tone stretch image for further retouching in Affinity 
Photo, which may have been saved in 16-bit precision.

However, you may find that 32-bit compositing is too demanding on your computer, in which case you can flatten after tone 
stretching and convert to 16-bit for better performance. I would then recommend you use the 16-bit macros, since they have 
various adaptations because 16-bit operates in gamma corrected space, as opposed to 32-bit’s linear space.

Main Macros



Macro Functionality

NEW:
(Live) Basic Tone Stretch
(Live) Arcsinh Tone Stretch
(Live) Structural Tone Stretch
(Live) Logarithmic Tone Stretch
(Live) Colour Preserving Tone Stretch
RGB/32

Run once you have all your data layers aligned and blended in one 
document.

If you are working with one shot colour (OSC) data, you won’t need to 
do anything. If you are working with mono data, you will likely want to 
colour map it using the Data Setup macros.

For the best result, delete the existing Curves and Levels adjustment 
layers that are created by default.

These are various hyperbolic stretches implemented in a non-
destructive manner that does not require layer merging—you may 
have to experiment with a couple of parameters to find the best result 
for your own imagery.

To configure the stretching to work for your data, expand the created 
Tone Stretch group to see a couple layers:

• Click the Stretch layer thumbnail for access to a Stretch Factor
slider that you can alter to control the overall strength of the 
stretch. There is also a Gamma slider for brightness.

• Click the Compression layer thumbnail for access to a 
Compression Blend slider. This controls the blend between two 
different compression methods: on the left, compression with 
more contrast (for punchier tones), and on the right, compression 
with more highlight preservation (for scenes with more dynamic 
range).

Do experiment with the different methods available: Asinh is a good 
all-rounder for most data. Colour Preserving works especially well for 
one shot colour data.

Neutral Tone Stretch
RGB/32

Run once you have all your data layers aligned and blended in one 
document.

For the best result, delete the existing Curves and Levels adjustment 
layers that are created by default.

Performs a weighted logarithmic transform then stretches the values 
in each colour channel to reveal object detail and give you a starting 
point for further retouching work. This is a good option to start with, 
then you can move onto the other methods below if you require a 
more colourful result (or wish to evaluate differences to see which you 
prefer). Above: Unstretched. Below: (Live) Arcsinh Tone Stretch 

Tone Stretching (JR - Astrophotography Stretches)



Macro Functionality

Normalised Tone Stretch
RGB/32

Run once you have all your data layers aligned and blended in one 
document.

For the best result, delete the existing Curves and Levels adjustment 
layers that are created by default.

Performs a nonlinear transform then stretches the values in each 
colour channel to reveal object detail and give you a starting point for 
further retouching work.

The tone stretching will reveal any background colour casts and 
gradients that may be present. With the Normalised Tone Stretch
layer selected, you can remove these by going to 
Filters>Astrophotography>Remove Background.

Logarithmic Tone Stretch
RGB/32

Performs a powerful logarithmic tone stretch that retains more colour 
intensity. This is a good option if you want slightly more colour detail as 
a starting point and feel that the Normalised Tone Stretch result is too 
neutral.

For the best result, delete the existing Curves and Levels adjustment 
layers that are created by default.

Colour Preserving Tone Stretch
Colour Preserving Tone Stretch (+)
RGB/32

Inspired by requests for an equivalent to Archsinh tone stretching, this 
performs tone stretching with superior colour preservation compared 
to the traditional Levels/Curves approach. Works best on broadband 
data—narrowband data may appear oversaturated, but do experiment 
as all data sets are unique.

For the best result, delete the existing Curves and Levels adjustment 
layers that are created by default.

There is also a (+) version, which will perform an additional nonlinear 
transform and histogram correction. This will really tease out fainter 
detail but may be overkill for most data—again, feel free to experiment 
and see whether it works for your imagery.

Above: Normalised Tone Stretch. Below: Colour Preserving Tone Stretch



Macro Functionality

Mono Stretch (RGB)
Mono Log Stretch (RGB)
Mono Stretch (L-RGB)
Mono Log Stretch (L-RGB)
Mono Stretch (SHO)
Mono Log Stretch (SHO)
RGB/32

Run once you have all your data layers aligned but BEFORE the colour 
mapping (achieved with the Data Setup macros).

For the best result, delete the existing Curves and Levels adjustment 
layers that are created by default.

Rather than tone stretching the composited, colour-mapped result, 
these macros will instead tone stretch each mono layer individually. 
You can colour map using the data setup macros before or after this 
process. I have found that this approach can yield some much better 
results for complex nebulae, and it’s easier to pull the colours apart 
and create a final image with more depth.

There are two methods available for RGB, L-RGB and SHO data sets: 
Mono Stretch, and Mono Log Stretch. The log stretch may work better 
for clean, high quality data. If the data is not optimal, I would advise 
trying the standard stretch. Do try both, however, and see which works 
better for you.

Note that this should be considered as an alternative to the existing 
tone stretching methods above, not a replacement! As always, 
experiment and see which methods work best for your data: indeed, 
you may find that one method may be exceptional for one set of data, 
but not another.

Stretch Selected Layer
Log Stretch Selected Layer
RGB/32

The mono data stretching macros also require masking to avoid 
overexposing bright detail: the masks for this process are based off an 
average of several different data sets.

You may find however that you need more manual control over this 
process: you can use these macros to stretch an individual layer that 
you have selected.

Alternatively, you might be using a non-conventional combination of 
data layers—such as enhancing an RGB composition with Ha—and 
you would need to stretch the Ha data individually.

A Stretched (Merge Down) layer will be created, with a Protect 
Highlights mask inside it.

Configure this mask until the highlight detail looks suitable for that 
data, then select the parent layer and use Layer>Merge Down to 
merge it into the initial data layer underneath. You can then repeat this 
process for all of your data layers until you are ready to colour map 
them.

Mono Log Stretch on Ha data



Macro Functionality

Enhance R (Mono) Layer
Enhance G (Mono) Layer
Enhance B (Mono) Layer
Enhance SII (Mono) Layer
Enhance Ha (Mono) Layer
Enhance OIII (Mono) Layer
RGB/32

Run once you have all your data layers aligned and blended in one 
document. If using the mono tone stretching method, perform the tone 
stretching first then use these afterwards.

To aid the mono data stretching process, there are also macros to 
enhance specific mono layers (e.g. SII, Ha, OIII, R, G, B etc). You can use 
these to bring out more detail for a specific data layer, e.g. if the SII 
detail was a bit faint and you wanted to enhance it.

Once a macro has been run, an additional layer will be created above 
the specified mono layer. You can change the opacity of this layer to 
control the amount of enhancement.

Boost R Layer
Boost G Layer
Boost B Layer
Boost SII Layer
Boost Ha Layer
Boost OIII Layer
RGB/32

Run once you have tone stretched your data and have begun the 
retouching/editing process.

These are designed to be used after the tone stretching process and 
further on in the edit. You may want to simply bring out some more 
colour or detail in a particular data layer such as OIII, or the G layer. 
This will copy the specific data layer, move it to the top and enhance 
its structure whilst preserving highlight detail.

Pre-Tone Stretch Denoise (RGB)
Pre-Tone Stretch Denoise (L-RGB)
Pre-Tone Stretch Denoise (SHO)
RGB/32

Run before tone stretching. Ensure your data layers are named 
according to the composition type (e.g. R, G and B, or SII, Ha and OIII).

Allows you to denoise the individual monochrome data layers before 
tone stretching—depending on your data, this may yield better results 
than denoising after tone stretching.

Post-Tone Stretch Denoise
RGB/32

Run once you have tone stretched your data and have begun the 
retouching/editing process.

After tone stretching, your imagery may contain both luminance and 
chrominance noise. This macro offers a reasonable attempt at noise 
reduction which will clean up the image. You can lower the opacity of 
the Post Tone-Stretch Denoise layer if the denoising is too aggressive.

Post-Tone Stretch Log Transform
RGB/32

Run once you have tone stretched your data and have begun the 
retouching/editing process.

Some imagery may require further tone stretching to pull detail away 
from the background. This option will bring out subtle detail, and has 
configurable range and blend sliders (click on the Post-Tone Stretch 
Log Transform layer thumbnail to bring these up).

Enhance SII (Mono) Layer



Highlight Recovery

Tone Manipulation

Macro Functionality

Tone Compression & Contrast
RGB/32

Provides a smooth tonal compression (avoiding harsh highlight detail) 
whilst also increasing general contrast across the image. This can be 
applied before or after further retouching as long as the document is 
still in 32-bit. Change the Tone Compression & Contrast layer opacity 
to control the strength of the effect.

Tone Compression & Gamma
RGB/32

Provides a smooth tonal compression (avoiding harsh highlight detail) 
and brightens the image. The effect is less aggressive compared to 
using Tone Compression & Contrast.

Darken Mono Stretched Result
RGB/32

When using the new mono data stretching macros, you will often find 
that the resulting composition is quite bright once all the layers are 
blended together. This will produce a pleasing brightness reduction, 
whilst also offering an optional non-linear brightness boost that will 
even out the contrast for trickier data.

To access the non-linear brightness boost, click on the Darken Mono 
Stretched Result layer thumbnail.

Highlight Recovery
RGB/32

If you are compositing multiple mono layers together (e.g. RGB, SHO), 
this macro can be used to recover any blown out highlight detail.

Note: this only works in 32-bit, as pixel values are ‘unbounded’, which 
means they can be greater than the 0-1 range. This means pixels 
brighter than 1 can be remapped to within a displayable range.

Click on the Highlight Recovery thumbnail and use the Highlights 
Range slider to configure the range of bright pixels that are recovered.

Generate Weighted Luminosity Layer
RGB/32
RGB/16

Best run after tone stretching and any basic tonal adjustments. 
Creates a layer set to a Luminosity blend mode based on the 
weighted greyscale intensity (or luminosity) of your image so far.

This allows you to use all manner of adjustments and filters to alter the 
colour detail in your image without affecting brightness. To do this, just 
make sure you add your layer work underneath the Weighted 
Luminosity layer (which will be placed at the very top of the layer 
stack).

NEW:
Live Denoise (Choma)
Live Denoise (Luma & Chroma)
RGB/32
RGB/16

Quickly applies a non-destructive Denoise filter with appropriate 
settings based on whether you’re using the 32-bit or 16-bit version.

Chroma will just remove colour noise. Luma & Chroma will also remove 
luminance noise (which will smooth detail out).



Macro Functionality

Polynomial Contrast Curve
RGB/32
RGB/16

Applies a non-destructive polynomial function with gamma correction 
to enhance contrast.

Click on the Polynomial Contrast Curve thumbnail to control individual 
red, green and blue channel gamma, allowing you to add a colour tint/
cast if required.

Punch & Saturation
RGB/32
RGB/16

Gives the image a little more contrast and saturation. The effect is 
blended out of the highlight detail to avoid clipping or brightening star 
detail and other intense areas.

Masked Gamma Stretch
RGB/32
RGB/16

Creates a structural mask that excludes star detail and applies it to a 
Levels adjustment, allowing you to perform a non-linear gamma boost. 
Especially useful when used with individual colour channels (e.g. 
raising gamma of a weaker colour channel without overexposing bright 
details).

Masked Curves Stretch
RGB/32
RGB/16

Performs a masked tone stretch that excludes bright star and nebula 
detail. Good for increasing brightness and contrast of darker areas.

Masked Contrast Boost
RGB/32
RGB/16

Applies a gentler curves adjustment that is masked to exclude bright 
detail. Useful for a general contrast enhancement without significantly 
brightening detail.

Highlight Preserving Tone Boost
RGB/16
RGB/32

Boosts shadows and mid tones whilst preserving highlight detail—this 
is achieved through a non-destructive mask calculation whose 
parameters can be altered.

Expand the Highlight Preserving Tone Boost group, then click on the 
Highlight Mask thumbnail to control the highlight threshold and mask 
fine tuning. Click on the Brightness / Contrast thumbnail to alter the 
actual brightness and contrast enhancement.

Highlight Preserving Brightness Boost
RGB/16
RGB/32

Boosts overall brightness whilst preserving highlight detail using blend 
ranges. Click on the Highlight Preserving Brightness Boost thumbnail 
to change the brightness value. Highlight Preserving Tone Boost



Macro Functionality

Highlight Protected Tone Lift
RGB/16
RGB/32

This has replaced the Final Tone Lift macro and is more or less the 
same: it simply lifts the overall brightness and contrast of your 
composition without overexposing the highlights.

A quick way to control the overall tone lift strength is to change the 
opacity of the Highlight Protected Tone Lift macro.

Nonlinear Tone Boost
RGB/16
RGB/32

A nice simple equation-filter option for achieving a tonal boost that 
focuses on raising darker tones. This is generally useful if you are 
trying to brighten up your composition but Curves or other adjustment 
layers just aren’t working.

Click the Nonlinear Tone Boost layer thumbnail for access to the 
Highlight Threshold slider. Moving this left will increase the tone boost.

Edge Masked Contrast
RGB/16
RGB/32

Produces a very subtle contrast enhancement to wide edge detail. 
Good for enhancing detail in large nebula objects.

Expand the Edge Masked Contrast group and click on the Bandpass 
Mask layer to the luminosity range graph, which will allow you to 
control the strength of the contrast enhancement.

Reduce Mid-Tone Contrast
RGB/16
RGB/32

Useful for flattening nebula detail if it has too much contrast. Uses 
blend ranges to avoid affecting the shadow and highlight tones.

Click the Reduce Mid-Tone Contrast thumbnail to change the contrast 
value.

Shadow Stretch
RGB/16
RGB/32

Uses Photo V2’s new live Luminosity Mask to apply a tonal stretch to 
shadows and mid-tones, leaving highlights alone. Useful for high 
contrast imagery where you need to ‘soften’ the transition between 
shadow and deep sky object detail.

Compress Highlights
RGB/32

Renders a smooth roll-off for highlights whilst preserving colour 
intensity.

Weighted Luminosity Enhancement
RGB/16
RGB/32

Calculates a weighted greyscale intensity based on the composited 
RGB data, then uses it to enhance luminance.

Click the Weighted Luminosity Enhancement thumbnail and use the 
Clamping slider to adjust brightness clamping.

Shadow Stretch and Weighted Intensity Mixer



Macro Functionality

Weighted Intensity Mixer
RGB/16
RGB/32

Lets you mix together different weighted intensity calculations based 
on the RGB channel data. This could be useful if you are struggling to 
balance the luminosity of your different colours and want to quickly 
experiment with various blends.

Click the Weighted Intensity Mixer thumbnail to access the various 
blending sliders.

Weighted RGB Tonal Boost
RGB/16
RGB/32

Lets you add a subtle brightness and tone boost with configurable 
RGB contribution, in addition to offset sliders which allow you to 
gradually raise the brightness of the colour channel information in a 
gentle, non-linear fashion.

Click the Weighted RGB Tonal Boost thumbnail to access weighting 
and offset sliders.

RGB Live Luminosity
RGB/16
RGB/32

Adds a single live filter layer that enables you to bring through 
luminosity data using single channel information or a mix of channel 
information.

Clickthe RGB Luminosity thumbnail, then alter the three contribution 
sliders to determine which mix of red, green and blue luminance 
information you would like.

Defaults to purely red channel information for a quick red channel 
luminance boost.

Min-Max Live Luminosity
RGB/16
RGB/32

Adds a single live filter layer that enables you to control luminosity 
using maximum and minimum RGB colour calculations.

Click the Min-Max Luminosity thumbnail then alter the Max and Min 
Strength contribution sliders to determine the contribution from each 
calculation, then use the Blend slider to control the balance between 
the two.

An additional Nonlinear Boost slider allows you to boost darker detail 
without overexposing highlight detail.

Extract Inferred Ha Luminance
RGB/16
RGB/32

Useful for when you don’t have separate Ha data to use for luminosity 
enhancement. Merges your layer work so far, then performs a 
logarithmic transform and channel manipulation to extract ‘inferred’ 
Ha data from the red channel. The resulting layer’s effect can be 
modified by changing its Opacity, or by clicking on the Luminosity 
Strength thumbnail and altering the Gamma slider.

Extract Inferred Ha Luminance



Star Size Reducer

Star Detail Retouching

Macro Functionality

Star & Background Separation (L)
Star & Background Separation (L) (+)
Star & Background Separation (S)
Star & Background Separation (S) (+)
RGB/32

Run after tone stretching, and please ensure any background 
gradients are already eliminated.

Splits the image into two layers: Starless and Stars. The macro may 
take some time to complete, and the star removal is not always 
foolproof (larger stars may remain).

This macro is very helpful if you want to retouch the object detail 
independently of the star detail. It doesn’t produce flawless starless 
images: for that, you would need StarNet++ or StarXTerminator.

However, if your intention is to keep the stars, but you want to modify 
the object detail independently (e.g. enhance structure, modify or 
boost colours), you can perform layer work underneath the Stars layer. 
You can even clip adjustments and live filters into the Stars layer, for 
example to reduce fringing or colouration.

There are four variants. (L) should be used for images with larger stars 
(or lower resolution). The (+) version is more aggressive and targets 
dimmer stars.
(S) should be used for images with smaller stars (or higher resolution), 
and the (+) version will target dimmer stars.

Star Size Reducer
RGB/16
RGB/32

Adds a live filter for non-destructive real time star size reduction. You 
can control the strength by altering the Star Size Reducer layer’s 
Opacity.

Please note: the live application is performance-intensive (hardware 
acceleration is advised) and also needs to be viewed at 100% zoom 
for accurate rendering.

Reduce Star Luminosity
RGB/16
RGB/32

Decreases star luminosity without reducing the size or shape. Useful 
for longer exposure results where star detail can tend to overpower 
the image.

Non-destructive application: click the Live Star Mask thumbnail to 
adjust threshold and smoothing for the star mask, and click the 
Luminosity thumbnail and alter the Luminosity Shift slider to alter the 
star reduction.

Reduce Star Intensity
RGB/16
RGB/32

Reduces size and overall intensity of star detail. Useful for broadband 
data where star detail is more prominent.

Note: the live Minimum Blur filter should be previewed at 100% zoom 
for an accurate representation. If the redrawing is too visually 
distracting, temporarily hide the layer whilst retouching, then show it 
again before exporting.

The Reduce Star Intensity layer has its own mask, which you can 
easily paint on with black to remove the effect from certain areas.



Background Detail Retouching

Macro Functionality

Reduce Background Luminosity
RGB/16
RGB/32

Darkens and de-emphasises the background by reducing its 
luminosity and saturation.

Non-destructive application: click the Live Background Mask
thumbnail to adjust threshold and smoothing for the background 
mask, and click the Luminosity thumbnail and alter the Luminosity 
Shift slider to control the background brightness. You can also modify 
the Saturation Shift slider to control background colour intensity.

Generally, altering the overall Opacity of the Reduce Background 
Luminosity layer is a great way to quickly change the strength of the 
effect.

Live Background Subtraction
RGB/16
RGB/32

Non-destructively removes background colour casts. The Sampled 
Colour Fill layer will be selected by default: use the Colour Picker on 
the Colour Panel to sample a background tone from your image, then 
click the picker icon to assign it.

Now show (enable) the Live Background Subtraction group and the 
background colour will be removed. If the background is too dark, click 
the Black Level Offset thumbnail and change the Output Black Level
slider.

Live Background Subtraction



Enhance Structure

Structure Retouching

Macro Functionality

Enhance Structure
Enhance Structure (Aggressive)
RGB/16
RGB/32

Enhances structure/texture—useful for bringing out fainter objects 
like nebula gas detail. Only blends into shadow and mid-range detail to 
avoid overexposing star highlights.

The Enhance Structure layer has its own mask: you can paint with 
black to subtract over areas where you don’t want structure 
enhancement. Alternatively, you can use Layer>Invert to make the 
mask black, then paint in with white over areas where you want 
structure enhancement,

You can also control the strength of the structure enhancement by 
changing the Enhance Structure layer’s Opacity.

The Aggressive version creates a new merged pixel layer at the top of 
the layer stack and applies a destructive filter, which results in 
stronger structural enhancement.

Within the Enhance Structure (Aggressive) layer you will find a mask 
layer, which can be used to control where the structural enhancement 
is being rendered. Don’t forget you can also change the opacity of the 
layer to alter the strength of the effect.

Enhance Nebula Structure
RGB/16
RGB/32

Similar to the Enhance Structure macros. Enhances nebula structure 
whilst aggressively excluding bright star detail. The Star Exclusion 
Mask can be controlled with minimum, maximum and highlight 
threshold parameters (accessible by clicking on its thumbnail).

Super Texture
RGB/32
RGB/16

Produces an incredibly strong textural enhancement effect.

The macro will create a mask and select it: you can immediately invert 
this (Layer>Invert) and paint back in with the Paint Brush Tool if you 
wish to selectively apply the effect.

The effect may also be far too strong by default: simply change the 
Super Texture layer opacity to reduce the strength.

Note: the 16-bit category version will look different (arguably superior) 
because it can use bilateral filtering which is not available with 32-bit 
float compositing.



Macro Functionality

Super Structure
RGB/32
RGB/16

Creates a dramatic structural enhancement on a new layer. The layer’s 
opacity can be lowered to reduce the strength of the effect.

Laplacian Structure Enhancement
RGB/32
RGB/16

Uses a laplacian pyramid technique (frequency decomposition) to 
enhance broader details in the image. The default effect may be too 
strong: simply reduce the Laplacian Structure Enhancement group 
opacity.

Upon expanding the Laplacian Structure Enhancement group, you will 
see several layers labelled by the amount of downsampling 
performed. Expand these to find either a Brightness/Contrast or 
Curves adjustment: manipulating the adjustments will let you fine tune 
the amount of enhancement each layer is contributing.

Alternatively, you can also alter the opacity of each layer.

Note: if you are seeing black “splotches” around edge detail (e.g. stars), 
please ensure you are using the 32-bit version on a 32-bit document.

Gaussian Difference Structure Enhancement
RGB/32
RGB/16

Uses a gaussian low pass technique to generate difference masks and 
uses them for Brightness / Contrast adjustment enhancement.

If you expand the Gaussian Difference Structure Enhancement group, 
you will find several adjustments named after the kernel value for each 
low pass filter used to generate the mask. Try adjusting the opacity of 
each layer to further configure the effect, or changing the opacity of 
the top level group to control the overall strength.

Local Contrast Structure
RGB/16
RGB/32

Combines a live High Pass filter with blend ranges and linear light 
blend mode—this enhances local contrast and brings out structural 
detail without crushing shadow or highlight detail.

Hue Masked Structure
RGB/16
RGB/32

Creates a configure setup that enhances clarity based on specific hue 
ranges.

Expanding the Compound Mask reveals two Colour Range layers that 
can be configured by clicking on their thumbnails. These default to 
red/orange and green/yellow colour ranges, but can be changed 
based on the dominant colours in your image.

Super Texture



Macro Functionality

Enhance Depth & Contrast
RGB/16
RGB/32

Enhances perceptual depth of the image (especially for complex 
nebulae) and also boosts colour.

Click the Enhance Depth & Contrast layer and type in a larger Radius
value for stronger enhancement, or reduce the layer opacity to lessen 
the effect.

Soften Structure
RGB/16
RGB/32

Uses a gamma transform layer setup and negative Clarity live filter to 
‘soften’ or reduce the crispness of textural detail—good for dimming 
star detail before using adjustments like Curves to bring nebula/other 
deep sky object detail forward.

Soft Rendering
RGB/16
RGB/32

Creates an interesting and pleasing rendering effect that softens and 
reduces star detail as well as diminishing background noise.

Change the opacity of the Soft Rendering layer to control its 
contribution. You can also access the Blend Ranges dialog to control 
its blending in more detail.

Enhance Depth & Contrast



Highlight Briliance

Effects

Macro Functionality

Diffuse Glow
RGB/16
RGB/32

Renders a pleasing diffuse light effect on highlights within the image 
and deepens bright colour detail. You can change the Diffuse Glow
layer’s opacity to increase or decrease the strength.

Highlight Brilliance
RGB/16
RGB/32

Adds an emphasis to highlight detail, making all stars in the image 
appear brighter and enhancing brighter nebula detail.

Non-destructive application: you can change the Highlight Brilliance
layer’s opacity, or click the layer thumbnail and change the Radius
value to alter the strength of the effect.

Subtle Contouring
RGB/16
RGB/32

Adds a very slight “contouring” or definition to detail, enhancing 
contrast slightly. Good to experiment with later on in the editing 
process.

Harsh Contouring
RGB/16
RGB/32

Similar to Subtle Conturing, but is far harsher with bringing out 
structure and edge contrast detail.



Reduce Harsh Noise

Corrective

Macro Functionality

Average Neutralisation
RGB/16
RGB/32

Creates a merged pixel layer based on your current layer stack, then 
creates an average flat colour representation. This is divided against 
the layer stack to ‘neutralise’ any prevalent colour casts—in 
practicality, it is useful for balancing out images that may be too strong 
in a particular colour channel.

Expand the Average Neutralisation layer and click the Neutralisation 
Parameters thumbnail to fine tune the effect: raise White Level if the 
effect is too dark, and lower Output Black Level to increase the 
strength of the effect.

Reduce Harsh Noise
Reduce Harsh Noise (+)
RGB/16
RGB/32

Adds a simple live blur blended into a very specific tonal range that 
helps to reduce harsh ‘blocky’ noise, which is typically difficult to 
remove using the traditional Luma noise reduction method.

Use the (+) version for stronger harsh noise removal (at the risk of 
blurring the image slightly).

Reduce Salt and Pepper Noise
RGB/16

16-bit only. Uses median filtering with custom blending to reduce 
blocky ‘salt and pepper’ noise which can sometimes occur when tone 
stretching monochrome data.

Altering the opacity of the Reduce Salt and Pepper Noise layer will 
control its overall strength.

Remove Star Fringing
Remove Star Fringing (Selective)
RGB/16
RGB/32

Adds a non-destructive defringing filter. If using the selective version, 
it will be masked just to star detail, which prevents loss of colour 
information in other deep sky objects.

Use this to combat fringing and chromatic abberation artefacting 
around stars—very typical of older optics like manual focus lenses 
adapted to modern camera mounts. Click the Remove Star Fringing
thumbnail and move the Fringe Colour slider to determine the fringing 
colour that you want to remove.

Reduce Magenta Star Colour
RGB/16
RGB/32

Quickly creates a masked adjustment that targets and desaturates 
intense magenta-coloured star detail.

Reduce the opacity of the Reduce Magenta Star Colour layer if the 
effect is too strong.



SCNR Green Neutral / Max Neutral

Macro Functionality

Brighten Star Centres
RGB/16
RGB/32

Sometimes, with aggressive masked stretching or stretching that 
protects highlight detail, you will find that star centres are darker than 
their surrounding glow areas and the result looks odd. This macro will 
create a star mask using a convolution filter and enhance the 
brightness of the star centres to try and mitigate this.

Expand Brighten Star Centres and click the Star Range Mask 
thumbnail to alter the luminosity mask that controls the star masking.

Click the Brighten Strength thumbnail and raise the Brightness slider 
to increase the intensity of the star brightening.

Green Channel Noise Reduction
RGB/16
RGB/32

Performs aggressive noise reduction on isolated green channel data, 
leaving red and blue channel data alone.

Green Channel Synthetic Substitution
RGB/16
RGB/32

Interpolates the green channel from a blend of red and blue channel 
data—useful for bi-colour compositions, or broadband compositions 
where green channel information would be mostly noise rather than 
meaningful data.

Double click the Green Channel Synthetic Substitution layer and use 
the Red/Blue Substitute slider to control the balance between red and 
blue channel data contribution.



Average Neutralisation

Macro Functionality

SCNR Green Max / Additive
RGB/16
RGB/32

An implementation of subtractive chromatic noise reduction used to 
reduce green channel noise, with the ability to blend non-destructively 
between maximum and additive methods.

Double click the SCNR Green Max/Additive layer to gain access to the 
Removal Strength slider and Maximum / Additive Method Blend slider.

SCNR Green Neutral / Max Neutral
RGB/16
RGB/32

An implementation of subtractive chromatic noise reduction used to 
reduce green channel noise, with the ability to blend non-destructively 
between maximum and additive methods.

Double click the SCNR Green Neutral / Max Neutral layer to gain 
access to the Neutral / Max Neutral Blend slider.

Nonlinear Compositing
RGB/32

There are other adjustments, filters and blending options whose 
behaviour will differ in 32-bit linear. Blend modes, for example, may not 
behave as expected. You might prefer how these render in 16-bit 
nonlinear.

This macro creates a nonlinear transform group—add your layer work 
in-between the Nonlinear and Linear transform layers to composite 
them in gamma corrected space.

Remove NaN Pixels
RGB/32

During editing in 32-bit float, you may come across odd pixels—they 
may perhaps be very intense in a particular colour channel. When a 
colour picker is used on them, they may report NaN.

Not-a-Number pixels can sometimes occur when particular blending 
operations (such as blend modes) and filters are used on unbounded 
pixel values. If these appear in your document after compositing, you 
can try running this macro to clamp them to within the 0-1 range of 
pixel values.



Masking

Macro Functionality

Live Star Mask
RGB/16
RGB/32

Adds a live filter that masks away background detail (leaving just stars) 
based on controllable threshold and smoothing values.

Click the Live Star Mask thumbnail for threshold and smoothing 
options.

To use: configure until you have the desired mask effect, then click-
drag the Live Star Mask layer over the thumbnail of the layer you wish 
to mask and release the mouse button.

Live Background Mask
RGB/16
RGB/32

Adds a live filter that masks away star detail based on controllable 
threshold and smoothing values.

Click the Live Background Mask thumbnail for threshold and 
smoothing options.

To use: configure until you have the desired mask effect, then click-
drag the Live Background Mask layer over the thumbnail of the layer 
you wish to mask and release the mouse button.

Live Channel Mask
RGB/16
RGB/32

Adds a live filter that masks based on colour channel contribution 
(defaults to full red channel).

Click the Live Channel Mask thumbnail for R, G and B contribution 
options.

To use: configure until you have the desired mask effect, then click-
drag the Live Channel Mask layer over the thumbnail of the layer you 
wish to mask and release the mouse button.

Live RGB Weighted Mask
RGB/16
RGB/32

Adds a live filter that masks based on weighted RGB values controlled 
by the user via an elevation-rotation input.

Click the Live RGB Weighted Mask thumbnail for weighting control 
and a clamping option.

To use: configure until you have the desired mask effect, then click-
drag the Live RGB Weighted Mask layer over the thumbnail of the 
layer you wish to mask and release the mouse button.

Live Star Mask



Macro Functionality

Weighted Saturation Mask
RGB/16
RGB/32

Saturates colour detail based on a weighted RGB mask.

Non-destructive application: click the Live RGB Weighted Mask
thumbnail to adjust weighting and clamping for the saturation mask, 
and click the HSL Adjustment thumbnail and alter the Saturation Shift
slider to control the overall saturation.

Use Layer as Mask
RGB/16
RGB/32

Takes your currently selected layer and allows it to be used as a mask 
non-destructively, as opposed to using Rasterise to Mask which is a 
destructive operation. You could, for example, use this on a stacked 
Luminance layer to use that data as a mask.

After running the macro, click-drag and drop your layer into the 
thumbnail of any other layer and it will become a mask. E.g. you could 
drop it into an HSL adjustment to saturate colour detail selectively.

Weighted Saturation Mask



OIII Ha Tone Enhancement

Colour Manipulation

Macro Functionality

Deepen Colour Detail
RGB/32

Uses an interesting differential blending technique to enhance colour 
detail in a natural-looking way.

Change the opacity of the Colour Structure group to control the 
strength of the colour saturation.

Vivid Colour Boost
RGB/16
RGB/32

Uses a weighted RGB transform to significantly enhance colour 
intensity, with a particular red bias. Reduce the Vivid Colour Boost
layer opacity if the effect is too strong.

Enhance DSO Luminosity
RGB/16
RGB/32

To further control the colour tones, expand the Enhance DSO 
Luminosity group, double click Colour Range Luminosity and move 
the Luminosity Shift slider for particular colour ranges.

Luminosity Masked Saturation
RGB/16
RGB/32

Creates a configurable setup that increases saturation based on two 
luminosity ranges combined together.

Expanding the Compound Mask reveals two Luminosity Range layers 
that can be configured by clicking on their thumbnails. By default, 
these mask through mid-tones and highlight tones so that darker 
background tones avoid being saturated.

Golden Boost
RGB/16
RGB/32

Uses the LAB colour model and blending to produce a rich gold/cyan 
look—works particularly well with false colour SHO images if you want 
the green Ha data to look unique and interesting.

Try experimenting with the Golden Boost layer’s blend mode—change 
from Hard Light to Overlay for a softer application for example. You 
can also experiment with the Opacity value.

SII Ha Tone Enhancement
RGB/16
RGB/32

Uses gradient mapping with blending techniques to enhance and 
bolden red/green tones commonly associated with Ha and SII signal 
data when creating false colour compositions (e.g. HSO, SHO).

OIII Ha Tone Enhancement
RGB/16
RGB/32

Uses gradient mapping with blending techniques to enhance and 
bolden blue/green tones commonly associated with OIII and Ha signal 
data when creating false colour compositions.



Enhance Colour Signals

Macro Functionality

Enhance Red Signal
Enhance Green Signal
Enhance Blue Signal
Enhance Cyan Signal
Enhance Magenta Signal
Enhance Yellow Signal
RGB/16
RGB/32

Very useful for quickly bringing out specific colour tones. Uses a 
combination of adjustment layers and blend modes to enhance colour 
ranges. There are a total of six macros which correspond to each 
colour range.

Each macro will provide a group layer. Simply change the opacity of 
this group to control the overall strength of the colour range 
enhancement.

Boost Red/Yellow Detail
Boost Blue/Green Detail
RGB/16
RGB/32

Compared to the Enhance Signal macros, the Boost Detail macros 
focus more on increasing colour intensity. They work incredibly well 
when used on broadband imagery, especially with galaxies and other 
objects that have fainter colour detail.

You can change the Opacity of the top level group to control the 
overall strength of the boost effect, or change the opacity of each 
individual layer within the group for further customisation.

Channel Masked White Balance
RGB/16
RGB/32

Alters white balance based on a colour channel mask.

Non-destructive application: double click the Live Channel Mask filter 
to adjust RGB contribution, and double click the White Balance layer 
to control white balance and tint.

Warm Red Tones
RGB/16
RGB/32

Targets a specific hue range of red and orange tones to ‘warm’ them 
and enhance the richness of the colours.

The opacity of the Warm Red Tones layer can be changed to control 
the strengh of the effect.

Cool Blue Tones
RGB/16
RGB/32

Targets a specific hue range of blue and cyan tones to ‘cool’ them and 
enhance the richness of the colours.

The opacity of the Cool Blue Tones layer can be changed to control 
the strengh of the effect.

Dual Band Colour Mixer
RGB/16
RGB/32

An experimental option: allows you to mix three different weighted 
intensity calculations for RGB channel data, producing a look similar to 
dual band compositions (e.g. HaOIII, HaSII). For further 
experimentation, try changing the layer’s blend mode to Saturation or 
Hue.

Click the Dual Band Colour Mixer thumbnail to access the red, green 
and blue mixing options.



Bandpass Sharpening (Micro) and Bandpass Sharpening (Fine) blended together

Sharpening

Macro Functionality

Bandpass Sharpening
(Micro)
(Fine)
(Regular)
(Wide)
RGB/16
RGB/32

Intended as a final sharpening step. This sharpening method performs 
the same multi-bandpass decomposition technique that is used with 
Absolute Point of Focus sharpening. It gives you very fine control in 
terms of enhancing different frequency ranges of detail in your image, 
and also increases perceptual ‘depth’ whilst avoiding over-sharpening 
noise.

Once running the macro, you have full control over the strength of 
each bandpass. Feel free to change the top group opacity, or change 
the opacity of individual Pass layers.

You can also hide individual Pass layers to remove the effect of that 
bandpass entirely. All of this flexibility allows you to completely fine-
tune the sharpening for your own imagery.

There are five variants (Repetitive is covered below) which each use 
different progressions for the bandpass values. Micro offers very fine 
detail enhancement, Fine offers slightly more enhancement, Regular
is suitable for most imagery and Wide will produce a stronger or 
‘wider’ contrast enhancement around edge detail.

Bandpass Sharpening (Repetitive)
RGB/16
RGB/32

Uses multiple bandpass filters all set to the same value.

Each pass gradually enhances detail and sharpness in a very subtle 
and refined way.

If the sharpening is too strong, click any of the Linked Bandpass layer 
thumbnails and change the Radius value to taste—this value is linked 
between all the filters.

Background Sharpening
RGB/16
RGB/32

Creates a masked group structure that sharpens dark and mid-tone 
detail, avoiding bright areas such as star detail. Very useful for avoiding 
black star halos around high contrast edges.

Expand the Background Sharpening group and double click the 
Sharpening Mask layer to access the Sharpening Scale option. If the 
sharpening is too weak or subtle, increase the scale value.



Gaussian Subtractive Sharpening

Macro Functionality

Gaussian Kernel Sharpening
RGB/16
RGB/32

Creates a top sharpening layer (based on your current layer work) 
masked to edge detail based on a gaussian kernel.

This is a really good method for sharpening bright star detail without 
producing noticeable halo artefacts around the edges.

Gaussian Subtractive Sharpening
RGB/16
RGB/32

Creates a non-destructive sharpening group based on a subtractive 
gaussian kernel method. The 32-bit version uses additional non-linear 
and linear transform stages to avoid “panda eyes” around bright star 
detail.

Within the main Gaussian Subtractive Sharpening group, you will find 
two sub-groups: Large Detail Sharpening and Small Detail 
Sharpening. You can hide/show these based on the size of object 
detail that you wish to sharpen, or change the Opacity to control their 
contribution.

Nonlinear Sharpening
RGB/32

Because 32-bit composites in linear space within Affinity Photo, you 
may find an Unsharp Mask or High Pass filter produces distracting 
black halos (“panda eyes”) around stars and other detail.

This macro non-destructively composites a live High Pass filter in 
gamma-corrected space, reducing these black halos. It is akin to 
sharpening in 16-bit nonlinear space, but you can do so without 
flattening and converting, so you can remain in 32-bit for the entire 
workflow.

A mask layer is automatically added and selected. You can 
immediately invert this if you wish (Mac: CMD+I, Windows: Ctrl+I), then 
begin painting on/off the mask with the Paint Brush Tool (B).

NEW:
Final Balance
Final Colour
Final Colour & Balance
Final Contrast
RGB/32
RGB/16

Once you reach the end of your editing, give these a try: they will 
generally try to balance out the tones (especially the background 
areas).

Final Balance will tackle any glaring contrast and channel balance 
issues.

Final Colour & Balance will do the above, but also try and correct any 
colour bias (e.g. white balance) issues.

Final Contrast is more light-handed, and will just modify contrast of 
the image if an adjustment is needed.



StarXTerminator: Extract Stars to Separate Layer (starless and stars layers)

StarXTerminator: Extract Stars to Separate 
Layer
RGB/32
RGB/16

Please note: this is not a replacement for StarXTerminator. It is 
designed to accelerate the process of separating the stars onto a 
separate layer so you can retouch both star and object detail 
separately.

To use: create a merged layer (Layer>Merge Visible), then run 
StarXTerminator to remove the stars. Now run this macro.

You will now be presented with two layers called Starless and Stars. 
You can retouch above the Starless layer but beneath the Stars layer 
for greater control over the object detail.

Other



The JR - Astrophotography Data Setups macro category is designed to speed up the colour mapping process for monochrome 
data once it has been stacked.

To use these macros, name your data layers accordingly (e.g. “Ha”, “OIII”, “SII” for a narrowband false colour composition, or “R”, “G”, 
“B”, “L” for an RGB composition with luminosity enhancement) then run the appropriate macro. Please note, the layer names are 
case sensitive, so be sure to use “OIII” rather than “oiii” for example.

New to V15 is the Extract OSC Layer to Mono RGB macro. This lets you take one layer from a one shot colour camera and split it 
into red, green and blue channel layers. You can then run the mono stretch macros such as Mono Log Stretch (RGB) on these 
separated layers to tone stretch the channel data separately. This will generally yield a much better result and give you much more 
detail to work with.

You will also find some one shot colour narrowband macros to help with colour blending when using one shot colour data that has 
been captured with dual/quad narrowband filters. These are work in progress and any feedback is appreciated.

Data Composition Setups



Macro Functionality

Rename Stacked Layers

Orders:

1. Ha, 2. OIII, 3. SII
1. Ha, 2. SII, 3. OIII
1. R, 2, G, 3, B
1. R, 2, G, 3. B, 4. L
1. L, 2, R, 3, G, 4, B
1. OIII, SII, Ha
1. OIII, Ha, SII
1. SII, OIII, Ha
1. SII, Ha, OIII
RGB/16
RGB/32

Several options for quickly renaming stacked layers if you’ve used file 
groups during stacking for multiple sets of data, which is 
recommended for speed and simplicity. Please see my official tutorial 
on how to use this feature:

https://youtu.be/Uu091-Rqfuw

These macros will speed up the layer renaming process which is 
required for the various composition setup macros to work (e.g. L-RGB, 
SHO, HSO).

When you stack using file groups, you will tag each file group with a 
particular data type such as Red, Green, Luminance, H-alpha etc. 
When you apply the stack and move to the main layer-based editing 
workspace, these data layers will appear like so:

You will typically add Luminance, Red or H-alpha as the first file group. 
Run the macro that corresponds to the ordering of the layers to 
quickly rename them:



L-RGB Composition Setup

Macro Functionality

Extract OSC Layer to Mono RGB
RGB/32

Takes one full colour data layer (e.g. from a DSLR, mirrorless or OSC 
astrophotography camera) and splits it into R, G and B mono data 
layers.

You can then run the mono tone stretching macros on these to obtain 
a much better result than just tone stretching the full colour layer.

Once you have tone stretched the mono layers, you can run the RGB 
Composition Setup macro to colour map them.

RGB Composition Setup
RGB/32

Automates the process of compositing monochrome RGB data. 
Recolours each monochrome layer, sets the appropriate blend mode, 
adds an optional Contribution adjustment to each layer (modify 
Gamma to alter the contribution) and provides a Channel Balance
layer to control the channel balance.

To use: stack your monochrome data using file groups, then name your 
layers R, G and B (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

L-RGB Composition Setup
RGB/32

Automates the process of compositing monochrome RGB data using 
Luminance data for luminosity enhancement.

To use: stack your monochrome data using file groups, then name your 
layers R, G, B and L (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HaRGB (Red Mix) Composition Setup
RGB/32

Automates the process of compositing monochrome RGB data with 
additional Ha (hydrogen alpha) data which is blended with the red 
channel data—you can alter the weighting by changing the opacity of 
the R and Ha layers.

To use: stack your monochrome data using file groups, then name your 
layers R, G, B and Ha (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

Ha-RGB (Luminosity) Composition Setup
RGB/32

Automates the process of compositing monochrome RGB data using 
additional Ha (hydrogen alpha) data for luminosity enhancement.

To use: stack your monochrome data using file groups, then name your 
layers R, G, B and Ha (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.



RGB-HaL Composition Setup

Macro Functionality

HaRGB-L Composition Setup
RGB/32

Automates the process of compositing monochrome RGB data with 
additional Ha data to contribute to the red channel, then Luminance 
data for luminosity enhancement.

To use: stack your monochrome data using file groups, then name your 
layers R, G, B, Ha and L (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

RGB-HaL Composition Setup
RGB/32

Automates the process of compositing monochrome RGB data, then 
an average of both Ha and Luminance data for luminosity 
enhancement.

To use: stack your monochrome data using file groups, then name your 
layers R, G, B, Ha and L (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

RGB-SHO Composition Setup
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and SHO composition, where the colour and narrowband data 
layers are averaged for each channel (R and SII, G and Ha, B and OIII).

To use: stack your monochrome data using file groups, then name your 
layers R, SII, G, Ha, B and OIII (important!). If you stacked your data 
layers separately and not with file groups, don’t forget to align all layers 
by selecting them then going to Arrange>Align Layers by Stars.

RGB-HSO Composition Setup
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and HSO composition, where the colour and narrowband data 
layers are averaged for each channel (R and Ha, G and SII, B and OIII).

To use: stack your monochrome data using file groups, then name your 
layers R, Ha, G, SII, B and OIII (important!). If you stacked your data 
layers separately and not with file groups, don’t forget to align all layers 
by selecting them then going to Arrange>Align Layers by Stars.



HaOIII Bi-colour Composition Setup

Macro Functionality

SHO Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into an SHO colour assignment.

To use: stack your monochrome data using file groups, then name your 
layers SII, Ha and OIII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HSO Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into an HSO colour assignment.

To use: stack your monochrome data using file groups, then name your 
layers Ha, SII and OIII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HOO Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into a bi-colour representation, where OIII provides both green 
and blue colour data.

To use: stack your monochrome data using file groups, then name your 
layers Ha and OIII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HaOIII Bi-Colour Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into a bi-colour representation, where both Ha and OIII are 
averaged for the green colour data.

To use: stack your monochrome data using file groups, then name your 
layers Ha and OIII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.



HOS Composition Setup

Macro Functionality

OSH Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into an OSH colour assignment. Recolours each monochrome 
layer, sets the appropriate blend mode, adds an optional Contribution
adjustment to each layer (modify Gamma to alter the contribution) 
and provides a Channel Balance layer to control the channel balance.

To use: stack your monochrome data using file groups, then name your 
layers OIII, SII and Ha (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

OHS Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into an OHS colour assignment. Recolours each monochrome 
layer, sets the appropriate blend mode, adds an optional Contribution
adjustment to each layer (modify Gamma to alter the contribution) 
and provides a Channel Balance layer to control the channel balance.

To use: stack your monochrome data using file groups, then name your 
layers OIII, Ha and SII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HOS Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into an HOS colour assignment. Recolours each monochrome 
layer, sets the appropriate blend mode, adds an optional Contribution
adjustment to each layer (modify Gamma to alter the contribution) 
and provides a Channel Balance layer to control the channel balance.

To use: stack your monochrome data using file groups, then name your 
layers Ha, OIII and SII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.



HaSII Bi-colour Composition Setup

Macro Functionality

HSS Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into a bi-colour representation, where SII provides both green 
and blue colour data. Recolours each monochrome layer, sets the 
appropriate blend mode, adds an optional Contribution adjustment to 
each layer (modify Gamma to alter the contribution) and provides a 
Channel Balance layer to control the channel balance.

To use: stack your monochrome data using file groups, then name your 
layers Ha and SII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HaSII Bi-colour Composition Setup
RGB/32

Automates the process of compositing monochrome narrowband 
data into a bi-colour representation, where both Ha and SII are 
averaged for the green colour data. Recolours each monochrome 
layer, sets the appropriate blend mode, adds an optional Contribution
adjustment to each layer (modify Gamma to alter the contribution) 
and provides a Channel Balance layer to control the channel balance.

To use: stack your monochrome data using file groups, then name your 
layers Ha and SII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HORGB Composition Setup (R+B)
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and HaOIII composition, where the colour and narrowband data 
layers are averaged for red and blue channel data (R and Ha, G, B and 
OIII).

To use: stack your monochrome data using file groups, then name your 
layers R, Ha, G, B and OIII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.



HORGB-L Composition Setup (R+B)

Macro Functionality

HORGB Composition Setup (G+B)
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and HaOIII composition, where the colour and narrowband data 
layers are averaged for green and blue channel data (R, G and Ha, B 
and OIII).

To use: stack your monochrome data using file groups, then name your 
layers R, G, Ha, B and OIII (important!). If you stacked your data layers 
separately and not with file groups, don’t forget to align all layers by 
selecting them then going to Arrange>Align Layers by Stars.

HORGB-L Composition Setup (R+B)
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and HaOIII composition enhanced with L data for luminosity, 
where the colour and narrowband data layers are averaged for red 
and blue channel data (R and Ha, G, B and OIII).

To use: stack your monochrome data using file groups, then name your 
layers R, G, Ha, B, OIII and L (important!). If you stacked your data 
layers separately and not with file groups, don’t forget to align all layers 
by selecting them then going to Arrange>Align Layers by Stars.

HORGB-L Composition Setup (G+B)
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and HaOIII composition enhanced with L data for luminosity, 
where the colour and narrowband data layers are averaged for green 
and blue channel data (R, G and Ha, B and OIII).

To use: stack your monochrome data using file groups, then name your 
layers R, G, Ha, B, OIII and L (important!). If you stacked your data 
layers separately and not with file groups, don’t forget to align all layers 
by selecting them then going to Arrange>Align Layers by Stars.

RGB-SHO Composition Setup (Mixed 
Luminance)
RGB/32

Automates the process of compositing monochrome data into a joint 
RGB and SHO composition, where the SHO data layers are averaged 
to enhance luminosity.

To use: stack your monochrome data using file groups, then name your 
layers R, G, B, SII, Ha and OIII (important!). If you stacked your data 
layers separately and not with file groups, don’t forget to align all layers 
by selecting them then going to Arrange>Align Layers by Stars.



Channel Swap R<>G

Macro Functionality

Dynamic Narrowband Mix
RGB/32

An implementation of the idea to dynamically mix Ha, SII and OIII 
colour data (based on a blog post from The Coldest Nights). This 
option tends to work best with SHO mapped data.

You can apply this before or after tone stretching. Click the Dynamic 
Narrowband Mix layer thumbnail to access the gamma sliders for 
each channel, as well as an additional Tri-Colour Mix slider which will 
blend in a dynamic mix for the blue channel.

Post-Stretch Gamma Mixing
RGB/32

A simple live gamma transform filter that can be applied after tone 
stretching to further alter the balance of each colour channel.

The interesting feature of this, however, is that the blend range is 
restricted to a very specific region of the luminosity. The idea is to help 
raise brightness of nebula detail but leave very dark and bright areas 
alone (so you are not also boosting the brightness of the background 
detail or overexposing star detail).

Click the Post-Stretch Gamma Mixing layer thumbnail to access the 
Red, Green and Blue Gamma sliders.

Channel Swap R<>G
Channel Swap R<>B
Channel Swap G<>B
RGB/32

Quick presets you can apply to completely swap channel data, 
allowing you to audition different narrowband colour combinations.

For example, if you used the SHO Composition Setup macro, you 
could use Channel Swap R<>G to quickly switch to an HSO 
composition instead, or you could use Channel Swap R<>B to try an 
OHS composition setup.

These options are non-destructive and you can simply delete the 
layers to return to your original composition.



Monochrome Colour Mapping

Macro Functionality

Ha Luminosity Setup
RGB/32

Automates the process of setting up an Ha data layer for luminosity 
enhancement—this is typically done with broadband RGB or one shot 
colour imagery to enhance hydrogen alpha emission areas.

To use: stack your Ha data, then copy/paste it into your main data 
document and align it (if necessary). Ensure you rename your Ha data 
layer to Ha then run the macro. It will automatically target the Ha layer, 
set its blend mode and provide an additional Luminosity Strength
adjustment. You can double click this and use the Gamma slider to 
control the overall luminosity enhancement.

Monochrome Colour Mapping
RGB/16
RGB/32

Run at the top of the layer stack after tone stretching has been 
performed.

Non-destructively maps greyscale data (e.g. just one Ha data layer) to 
a controllable colour range, which defaults to red for a false-colour Ha 
composition.

To tailor the colour mapping to your own data result, expand the 
Monochrome Colour Mapping group.

• Double-click Colour Mapping and move the second black node 
to control the range of tones that receive colour.

• Double-click Black Level and change Output Black Level if the 
result is too dark or bright.

• You can use the other adjustment layers such as Brightness & 
Contrast, Saturation, Luminosity and Colour to tweak the colour 
mapping result further.

Greyscale Solar to False Colour Setup
RGB/32

Intended specifically for greyscale solar imagery of the sun. This 
macro will take a greyscale document, convert it to full colour (RGB 16-
bit), and apply the following operations, all of which are configurable:

• Highlight Recovery

• Colour Mapping (with separate R, G and B gamma controls)

• Brightness Boost

• Yellow colour enhancement

• Softening of detail contrast

• Optional structure enhancement



Moon Processing Workflow

Macro Functionality

Moon Processing Workflow (16-bit)
RGB/16

Designed for stacked imagery of the moon using Affinity Photo’s 
File>New Stack functionality, which lets you align, stack and average 
pixel content using Median and Mean operators.

This macro will perform a number of initial steps:

• Flatten and convert to 16-bit per channel format

• Separate colour and luminosity

• Provide preset HSL layers underneath the luminosity layer so you 
can saturate and bring out colour detail

• Add a live defringing filter to colour fringing around the edges of 
the moon (feel free to hide if your image doesn’t have this)

• Perform structure and highlight detail enhancement with 
configurable non-destructive layers

• Add final band-pass sharpening and fine detail sharpening, which 
are again configurable

Merge to 16-bit sRGB
RGB/32

Run anywhere in the layer stack after tone stretching has been 
performed.

Groups all of your existing layer work, then creates a merged pixel 
layer before converting to 16-bit precision with an sRGB colour profile.

This is useful if you want to use the Median Blur filter, which is 
unavailable in 32-bit. 16-bit is also less performance-intensive, so this 
may help for less powerful hardware setups.

Merge to 16-bit Wide Gamut
RGB/32

Performs the same function as Merge to 16-bit sRGB, but instead 
converts to ROMM RGB (ProPhoto), which is a significantly wider 
colour gamut and allows for more intense colour detail. 



Credits
All astrophotography retouching and editing by James Ritson. Data gathered using own equipment and remote imaging services iTelescope and 
Telescope Live.


